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01 02 03
Introduction Technology Hands-on

Bosch and Bosch Sensortec. Our technical solutions. Now it’s your turn.
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Low entry barrier
Hands-on Session

How to easily start working with sensors?

How to evaluate sensor data?
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Use Smart Device and App
Hands-on Session

1. Get phyphox mobile app at https://phyphox.org/

2. Read sensors and log data 

3. Download and process data, compute offset, noise, sensitivity, etc

4. Further step…

create your own experiment at https://phyphox.org/editor/
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Use Smart Device and App
Hands-on Session

1. Statistics Accelerometer

2. Statistics Accelerometer/Gyroscope

3. Sensitivity Gyroscope
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Use Smart Device and App
Hands-on Session

1. Statistics Accelerometer

2. Statistics Accelerometer Gyroscope

3. Sensitivity Gyroscope

9



Nicla Sense ME

Hands-on Session



Bosch Sensortec | Consumer Inertial MEMS – High Tech in your hands | 2023-12-01

© Bosch Sensortec GmbH 2021. All rights reserved, also regarding any disposal, exploitation, reproduction, editing, distribution, as well as in the event of applications for industrial property rights.

Agenda
Nicla Sense ME Hands-on Session

Agenda

1

2

3

4

Getting started

Exercise for you

Exercise together

Outro - feedback
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Nicla Sense ME
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Parameter Technical data 

Processor 64 MHz Arm® Cortex M4 (nRF52832) 

I/O 

Castellated pins with the following features:

• 1x I2C bus (with ext. ESLOV)

• 1x serial port

• 1x SPI

• 2x ADC

• Programmable I/O voltage from 1.8-3.3V

Dimensions 22,86 mm x 22,86 mm 

Power 
• USB

• Pin Header

• 3.7V Li-po battery, Integrated charger

Connectivity Bluetooth 5, BLE

Memory 
• 512KB Flash / 64KB RAM

• 2MB SPI Flash for storage

• 2MB QSPI dedicated for BHI260AP

Interface USB interface with debug functionality 
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Introduction
Bosch Sensors

BHI260AP

Smart sensor that includes in one package many software functionalities, 

32-bit customer programmable microcontroller, 6-axis IMU.

• Self-learning AI software

• Low power pedestrian position tracking

• Personalized fitness tracking & swim analytics

BMM150

Low-power, low-noise 3-axis digital geomagnetic sensor, provides absolute spatial orientation 

and motion vectors with high accuracy and dynamics via dedicated data fusion software.

• Outdoor/indoor navigation

• Head movement tracking
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Introduction
Bosch Sensors

BME688

The first gas sensor with Artificial Intelligence (AI) and integrated high-linearity and 

high-accuracy pressure, humidity and temperature sensors.

VOCs and other gases (e.g., CO and H) detection in the ppb range.

• Specific detection of Volatile Sulfur Compounds (VSCs)

• Application-specific gas scanner

• BME AI-Studio software

BMP390

Small, low-power and low-noise 24-bit absolute barometric pressure sensor.

Digital, high-performance sensor for a wide range of altitude tracking applications 

(smartphones, GPS modules, wearables, hearables, drones, etc.)

• Unique accuracy and stability

• Lowest noise
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Environment Setup
Getting Started

Tool Chain Setup:

• Arduino IDE 1.8.19

• Open from Tools -> Manage Libraries: "Arduino_BHY2", "Arduino_BHY2Host", "ArduinoBLE“

• Open from Tools -> Boards Manager: "Arduino Mbed OS Nicla Boards“

• File -> Examples -> Arduino_BHY2 -> Standalone

press on Verify to check that it compiles 
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Web Resources
Getting Started

Nicla Sense ME - User Guide, Technical Specifications & Product Documentation

Bosch Sensortec Community

Arduino IDE Download Page

Learn more about:

• BHI260AP

• BMM150

• BME688

• BMP390

Sensor Classes

Sensor IDs
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https://store.arduino.cc/nicla-sense-me
https://community.bosch-sensortec.com/
https://www.bosch-sensortec.com/products/smart-sensors/bhi260ap/
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Read Sensors Data
Getting Started

#include "Arduino_BHY2.h"

// Create a reference to the accel sensor

SensorXYZ accel(SENSOR_ID_ACC);

void setup() {

}

void loop() {

}

Sensor Classes

▪ Sensor: single values (e.g., temperature, pressure, …)

▪ SensorXYZ: XYZ values (e.g., accel, gyro, …)

▪ …

Sensor IDs
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Read Sensors Data
Getting Started
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Read Sensors Data
Getting Started
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Read Sensors Data
Getting Started

#include "Arduino_BHY2.h"

#define ACCEL_FS8G_CONV_FACTOR 0.24414

// Create a reference to the accel sensor

SensorXYZ accel(SENSOR_ID_ACC);

void setup() {

// Setup the serial communication

Serial.begin(115200);

while(!Serial);

// Setup the BHY and the sensors of interest

BHY2.begin();

accel.begin();

}

void loop() {

// Update function should be continuously polled

BHY2.update();

// Print data

Serial.print(String("X:") + String(accel.x() *

ACCEL_FS8G_CONV_FACTOR));

Serial.print(",");

Serial.print(String("Y:") + String(accel.y() *

ACCEL_FS8G_CONV_FACTOR));

Serial.print(",");

Serial.println(String("Z:") + String(accel.z() *

ACCEL_FS8G_CONV_FACTOR));

}
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Sensor Data on LED
Exercise for you

▪ Task:

show the data you prefer

on the RGB LED

▪ Including Nicla library
#include <Nicla_System.h>

▪ In the setup() function
// Setup the Nicla library and the LED

nicla::begin();

nicla::leds.begin();

// Configure the built-in LED as output

pinMode(LED_BUILTIN, OUTPUT);

▪ In the loop() function
// Setting LED color:

nicla::leds.setColor(cyan);

// function input can be a single keyword

(off, red, green, blue, yellow. Magenta, cyan)

// or also the three RGB values from 0 to 255 for red, green and blue

nicla::leds.setColor(red_val, green_val, blue_val);

▪ Extra: how not to run the loop as fast as possible:

void loop(){

static auto lastCheck = millis();

BHY2.update();

If (millis() - lastCheck >= 150){

// your code here

lastCheck = millis();

}

}
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Exercise – An example
Gravity on RGB LED

#include "Arduino_BHY2.h"

#include <Nicla_System.h>

#define DEBUG

#define ACCEL_FS8G_CONV_FACTOR 0.24414

// Create the structure which will contain time and data

struct Data {

float ts;

float x;

float y;

float z;

};

// Create a reference to the accel sensor

SensorXYZ accel(SENSOR_ID_ACC);

void setup() {

// Setup the serial communication

Serial.begin(115200);

while(!Serial);

// Setup the BHY and the sensors of interest

BHY2.begin();

accel.begin();

// Setup the Nicla library and the LED

nicla::begin();

nicla::leds.begin();

// Configure the built-in LED as output

pinMode(LED_BUILTIN, OUTPUT);

}
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Exercise – An example
Gravity on RGB LED

void loop() {

// Static time, stored only the first iteration

static auto now = millis();

// Update function should be continuously polled

BHY2.update();

// Do something after every 250 ms

if (millis() - now >= 250) {

now = millis();

// Read the accel content

Data data { now, accel.x(), accel.y(), accel.z() };

// Color logic:

// - Ratio of each axis to accel magnitude mapped to (0, 255) range

float magnitude = sqrt(pow(data.x, 2) + pow(data.y, 2) + pow(data.z, 2));

short red = abs(data.x)/magnitude * 255;

short green = abs(data.y)/magnitude * 255;

short blue = abs(data.z)/magnitude * 255;

nicla::leds.setColor(red, green, blue);

#ifdef DEBUG // Print debug messages

Serial.println(String("time [ms]: ") + String(data.ts));

Serial.println(String("acceleration [mg]:"));

Serial.println(String("\tX: ") + String(data.x * ACCEL_FS8G_CONV_FACTOR));

Serial.println(String("\tY: ") + String(data.y * ACCEL_FS8G_CONV_FACTOR));

Serial.println(String("\tZ: ") + String(data.z * ACCEL_FS8G_CONV_FACTOR));

#endif

}

}
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Sensor Data Leveraging

How can we fully leverage our sensors?
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Data Fusion
Guided exercise

Combining two different measurement sources of the same information 

to improve its accuracy.

Target Pitch angle 

Source n.1 Accelerometer

Source n.2 Gyroscope

29



Bosch Sensortec | Consumer Inertial MEMS – High Tech in your hands | 2023-12-01

© Bosch Sensortec GmbH 2021. All rights reserved, also regarding any disposal, exploitation, reproduction, editing, distribution, as well as in the event of applications for industrial property rights.

Guided exercise
Data Fusion

Accelerometer as inclinometer Gyroscope output integration

𝜃 = arctan
𝛼𝑥

𝛼𝑦
≈

𝛼𝑥

𝛼𝑦

𝜃 = 𝜃0 + 𝑔𝑧Δ𝑡
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Complementary Filter
Guided exercise

[Ref]
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previous

https://vanhunteradams.com/Pico/ReactionWheel/Complementary_Filters.html
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Complementary Filter - pt1
Guided exercise

#include "Arduino_BHY2.h"

#include "math.h"

#define ACCEL_LSB2MG_FS8 0.24414

#define GYRO_LSB2DPS_FS2000 0.06104

// Reference to accel and gyro sensors

SensorXYZ accel(SENSOR_ID_ACC);

SensorXYZ gyro(SENSOR_ID_GYRO);

float now = 0;

float pitch_accel = 0;

float pitch_gyro = 0;

float pitch_rawgyro = 0;

float pitch_filt = 0;

float dt = 0;

const float alpha = 0.98;

void setup() {

// Setup serial communication

Serial.begin(115200);

while(!Serial);

// Start BHY and sensors

BHY2.begin();

accel.begin();

gyro.begin();

}
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Complementary Filter - pt2
Guided exercise

void loop() {

// Update function should be continuously polled

BHY2.update();

// Update delta time [s]

dt = (millis() - now)/1000;

now = millis();

// Update pitch from single sources

pitch_accel = atan2(-accel.x(), sqrt(pow(accel.y(), 2) + pow(accel.z(), 2))) * 180/PI;

pitch_rawgyro -= dt * gyro.y() * GYRO_LSB2DPS_FS2000;

// Pitch from complementary filter

pitch_gyro = pitch_filt - dt * gyro.y() * GYRO_LSB2DPS_FS2000;

pitch_filt = alpha * pitch_gyro + (1 - alpha) * pitch_accel;

// Print messages

Serial.print(String("Accel:") + String(pitch_accel));

Serial.print(",");

Serial.print(String("Gyro:") + String(pitch_rawgyro));

Serial.print(",");

Serial.println(String("Filter:") + String(pitch_filt));

}
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Orientation Virtual Sensor
Guided exercise

#include "Arduino_BHY2.h"

#include "math.h"

#define ACCEL_LSB2MG_FS8 0.24414

#define GYRO_LSB2DPS_FS2000 0.06104

// Create a reference to accel and gyro sensors

SensorXYZ accel(SENSOR_ID_ACC);

SensorXYZ gyro(SENSOR_ID_GYRO);

SensorOrientation orientation(SENSOR_ID_ORI);

float now = 0;

float pitch_accel = 0.0;

float pitch_gyro = 0.0;

float dt = 0;

void setup() {

// Setup the serial communication

Serial.begin(115200);

while(!Serial);

// Setup the BHY and the sensors of interest

BHY2.begin();

accel.begin();

gyro.begin();

orientation.begin();
BHY2.configureSensor(SENSOR_ID_ACC, 100, 1);

BHY2.configureSensor(SENSOR_ID_GYRO, 100, 1);

}

void loop() {

// Update function should be continuously polled

BHY2.update();

// Update delta time [s]

dt = (millis() - now)/1000;

now = millis();

pitch_accel = atan2(accel.x(), sqrt(pow(accel.y(), 2) + pow(accel.z(), 2))) * 180/PI;

pitch_gyro += dt * gyro.y() * GYRO_LSB2DPS_FS2000;

// Print messages

Serial.print(String("Accel:") + String(pitch_accel));

Serial.print(",");

Serial.print(String("Gyro:") + String(pitch_gyro));

Serial.print(",");

// WATCHOUT! Due to a bug in the current release, roll and pitch are currently exchanged

Serial.println(String("Orientation:") + String(orientation.roll()));
}
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WebBLE Dashboard
▪ Arduino Nicla Sense ME - Web BLE test in Chrome browser
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Internship Master thesis PhD Program Direct Entry

6 Months paid 

internship for 

Bachelor and 

Master Students

6 Months paid 

Master-thesis in 

collaboration with 

your University

3 years program in 

collaboration with a 

University

Start your Career as 

an Engineer after 

your Master Degree

Joining Bosch Sensortec
University program
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@BoschMEMS

www.bosch-sensortec.com

community.bosch-sensortec.com

linkedin.com/company/bosch-sensortec

GET IN 

TOUCH 

WITH US

youtube.com/user/BoschSensortec

Bosch Automotive Electronics

Bosch Sensortec

Bosch Italia
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https://twitter.com/BoschMEMS
https://www.bosch-sensortec.com/
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